A suggestion to deleting the network name from the copied address text

When copying the address in the upper left
The network name is also copied along with the address
Which makes it difficult to transfer and transact
I suggest deleting the network name from the copied address text.

matic:0x7365019c159CC3A8812d0e30e6F5FefCf269C212 == > 0x7365019c159CC3A8812d0e30e6F5FefCf269C212

1 Like

You can control this in Settings → Appearance → “Copy addresses with chain prefix”